Cisco 1131AG

 

Появилась возможность поиграться с Cisco Aironet 1131AG. Как известно, беспроводные точки доступа cisco могут работать в двух режимах - облегченном (LAP`ы, в паре только с контролером) и в стационарном(AP`ы, самостоятельно). На руках у меня оказались LAP - AIR-LAP1131AG. Конечно же сразу стало интересно превращение из LAP`а в AP. Скачал ПО с сайта для точки и все необходимы утилиты для ее прошивки.  Перепрошить получилось, сама процедура перепрошивки немного специфическая, похожа на шаманские действия. Помимо перепрошивки интересно было попробовать это оборудование в следующей схеме: Multi SSID`ность с разбросом по разным vlan`ам - например OfficeVIP и Office, для привилегированных и рядовых сотрудников, для каждого SSID`а свой dhcp сервер, возможность nat трансляций для каждого vlan`а, это к примеру если брать Интернет с реальным ip адресом у разных Интернет-операторов. Увы NAT трансляции настроить не удалось,  так же как и отдельные dhcp сервера. Возможно это как-то завязано на ОС, которая установлена и запущена на точке. В моем случае nat команд  в IOS`е вообще не было, а возможность создания pool`ов dhcp были, но клиенты отказывались получать ip адрес динамически, даже попыток в debug режиме не наблюдалось на получение ip адреса. Удалось создать multi SSID`ы, и подключаться клиентскими устройствами в свои vlan`ы, но ip адреса на клиентах пришлось прописывать ручками. Полагаю, если поставить отдельное устройство осуществляющее nat трансляции и dhcp для этих vlan`ов, то все заработает - например cisco 18xx серии. Получается, что если бы точка умела все перечисленное при работе в стационарном режиме,  то стала бы очень универсальной, и сравнивая с той же 18xx серией и потребностями для небольших офисов, надобность в последней отпала бы. Ниже конфигурационные выжимки для двух SSID`ов:


dot11 mbssid
dot11 vlan-name VipOffice vlan 200
dot11 vlan-name Office vlan 300
!
dot11 ssid VipOffice
    vlan 200
    authentication open
    mbssid guest-mode
!
dot11 ssid Office
    vlan 300
    authentication open
    mbssid guest-mode
!
interface Dot11Radio0
no ip address
no ip route-cache
encryption vlan 200 key 1 size 128bit 7 D3F9F2CCCCCCCE39F38DD7A48536 transmit-key
encryption vlan 200 mode ciphers aes-ccm tkip wep128
encryption vlan 300 key 1 size 40bit 7 FFFFFFFFF653 transmit-key
encryption vlan 300 mode wep mandatory
ssid Office
ssid VipOffice
speed basic-54.0
channel 2412
station-role root
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
bridge-group 1 spanning-disabled
!
interface Dot11Radio0.200
encapsulation dot1Q 200
ip address 192.168.30.1 255.255.255.0
no ip route-cache
bridge-group 200
bridge-group 200 subscriber-loop-control
bridge-group 200 block-unknown-source
no bridge-group 200 source-learning
no bridge-group 200 unicast-flooding
bridge-group 200 spanning-disabled
!
interface Dot11Radio0.300
encapsulation dot1Q 300
ip address 192.168.50.1 255.255.255.0
no ip route-cache
bridge-group 255
bridge-group 255 subscriber-loop-control
bridge-group 255 block-unknown-source
no bridge-group 255 source-learning
no bridge-group 255 unicast-flooding
bridge-group 255 spanning-disabled
interface FastEthernet0
no ip address
no ip route-cache
duplex auto
speed auto
bridge-group 1
no bridge-group 1 source-learning
bridge-group 1 spanning-disabled
!
interface FastEthernet0.200
encapsulation dot1Q 200
no ip route-cache
bridge-group 200
bridge-group 200 subscriber-loop-control
bridge-group 200 block-unknown-source
no bridge-group 200 source-learning
no bridge-group 200 unicast-flooding
bridge-group 200 spanning-disabled
!
interface FastEthernet0.300
encapsulation dot1Q 300
no ip route-cache
bridge-group 255
bridge-group 255 subscriber-loop-control
no bridge-group 255 source-learning
bridge-group 255 spanning-disabled
!
interface BVI1
ip address dhcp client-id FastEthernet0
no ip route-cache


Для каждого vlan`а включил WEP с разными ключами. Бросилось в глаза, что WPA2 отсутствует.

Level Up
Sponsors:

Контактная информация

Если у Вас есть какие-либо вопросы, Вы можете связаться с нами:

Отдел продаж: (с 10:00 до 18:00)

Icq: 155-10-6525

E-mail: sales@golas.ru