Поглощаем MPLS сеть или Inter-as mpls option C

Операторов покупают и продают, приходится сталкиваться с потребностью в поглощении другой сети. Попробуем реализовать схему поглащения с высокой надежностью. Предположим есть два Интернет-оператора обладающие своими собственными MPLS сетями. В каждом Интернет-операторе для распространения ip адресов Loopback интерфейсов используется протокол динамической маршрутизации OSPF. В каждой из сетей имеется не менее двух Route-Reflector`ов(RR). У одного(Интернет-оператор А) внутри MPLS сети для распространения vpnv4 и vpnv6 таблиц используется приватная автономная система — AS65000. BGP сессии внутри этой AS подняты с Loopback интерфейсов на приватных ip адресах. У второй(Интернет-оператор В) MPLS сети для распространения vpnv4 и vpnv6 таблиц используется приватная автономная система — AS64000. BGP сессии внутри этой AS подняты с Loopback интерфейсов на реальных ip адресах. Физическое соединение между операторами для организации надежности реализовано через два 10G оптических стыка. См. рисунок, при нажатии на рисунок большая детализация.

Основная задача после объединения MPLS сетей — как можно проще и прозрачнее производить настройку оборудования для предоставления L2VPN и L3VPN сервиса.

После проверки работоспособности в лаборатории с тюнингованными настройками BGP и OSPF в связке с BFD, а так же при поднятой хотя бы одной из BGP сессий, клиенты, в аварийной ситуации, даже не заметят процесса автоматического переключения их EoMPLS каналов точка-точки или перемаршрутизации в vrf таблицах. Полагаю L2VPN`ы для точка-многоточка на ES картах будут вести себя аналогично, вопрос остается только в том, где располагать vfi хабы, в одной AS или в обоих. Завязывая между собой vfi хабы разных AS. По мне, так второй вариант более интересен с точки зрения экономии полос пропускания. Ниже основные выжимки из конфигурационных файлов по настройке.

Настройка PE маршрутизаторов внутри Интернет-оператора A (AS65000)

  • Согласовать название vrf, rd и route-target`ы с оператором В.
  • Создать vrf с согласованным названием, прописать rd с префиксом своей AS и согласованной частью, прописать только свои согласованные import/export target`ы с префиксом своей AS.
  • Если не установлено, установить с PE маршрутизаторов только vpnv4/vpnv6 сессии с двумя RR своей собственной AS(ipv4 сессии не устанавливаем).
  • Произвести дистрибуцию присоединенных маршрутов созданной vrf таблицы.

 

Пример настройки PE маршрутизатора Интернет-оператора А:

 
vrf definition vpnA
 rd 65000:150
 address-family ipv4
 route-target export 65000:150
 route-target import 65000:150
 exit-address-family
 
mpls traffic-eng tunnels
mpls ldp loop-detection
mpls ldp graceful-restart
 
interface Loopback0
 ip address x.x.1.50 255.255.255.255
 
interface GigabitEthernet0/0
 description RR1_65000
 mtu 1600
 ip address x.x.126.201 255.255.255.254
 ip mtu 1546
 ip ospf network point-to-point
 ip ospf hello-interval 1
 mpls mtu 1576
 mpls traffic-eng tunnels
 mpls ip
 bfd interval 50 min_rx 50 multiplier 3
 
interface GigabitEthernet0/1
 description RR2_65000
 mtu 1600
 ip address x.x.126.203 255.255.255.254
 ip mtu 1546
 ip ospf network point-to-point
 ip ospf hello-interval 1
 mpls mtu 1576
 mpls traffic-eng tunnels
 mpls ip
 bfd interval 50 min_rx 50 multiplier 3
 
interface FastEthernet0/0/0.150
 vrf forwarding vpnA
 encapsulation dot1Q 150
 ip address 172.20.1.1 255.255.255.0
       
interface FastEthernet0/0/0.250
 description l2vpn
 encapsulation dot1Q 250
 xconnect z.z.240.136 250 encapsulation mpls
 
router ospf 333
 router-id x.x.1.50
 ispf
 log-adjacency-changes
 timers throttle spf 100 500 5000
 timers throttle lsa all 100 500 5000
 timers lsa arrival 150
 timers pacing flood 15
 timers pacing retransmission 30
 passive-interface default
 no passive-interface GigabitEthernet0/0
 no passive-interface GigabitEthernet0/1
 network x.x.1.0 0.0.0.255 area 0
 network x.x.126.200 0.0.0.1 area 0
 network x.x.126.202 0.0.0.1 area 0
 bfd all-interfaces
 
router bgp 65000
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor x.x.1.9 remote-as 65000
 neighbor x.x.1.9 update-source Loopback0
 neighbor x.x.1.10 remote-as 65000
 neighbor x.x.1.10 update-source Loopback0
       
 address-family vpnv4
  neighbor x.x.1.9 activate
  neighbor x.x.1.9 send-community both
  neighbor x.x.1.10 activate
  neighbor x.x.1.10 send-community both
 exit-address-family
 
 address-family ipv4 vrf vpnA
  redistribute connected
 
mpls ldp router-id Loopback0 force
 

Пример настройки RR маршрутизатора Интернет-оператора А:

  • Устанавливаем BGP с PE маршрутизатором являющимся RR клиентом
  • Настраиваем на интерфейсе пересылку меток через bgp
  • В bgp ipv4 делаем посылку меток PE маршрутизатору
  • В bgp vpnv4 делаем next-hop-unchanged

 

mpls traffic-eng tunnels
mpls ldp loop-detection
mpls ldp graceful-restart
 
interface Loopback1
 ip address x.x.1.10 255.255.255.255
 
interface GigabitEthernet1/1
 description test-lab1-bb Gi1/2
 mtu 9000
 ip address x.x.126.255 255.255.255.254
 ip mtu 1546
  ip ospf network point-to-point
 ip ospf hello-interval 1
 ip ospf mtu-ignore
 mls qos trust cos
 mpls mtu 8000
 mpls traffic-eng tunnels
 mpls ip
 bfd interval 50 min_rx 50 multiplier 3
 
interface GigabitEthernet1/2
 description test-lab3-bb Gi1/1
 mtu 9000
 ip address y.y.17.125 255.255.255.252
 ip mtu 1546
 mpls mtu 8000
 mpls traffic-eng tunnels
 mpls bgp forwarding
 bfd interval 50 min_rx 50 multiplier 3
 
interface GigabitEthernet3/48
 description pe1_65000 Gi0/1
 mtu 1600
 ip address x.x.126.202 255.255.255.254
 ip mtu 1546
 ip ospf network point-to-point
 ip ospf hello-interval 1
 mpls mtu 1576
 mpls traffic-eng tunnels
 mpls ip
 bfd interval 50 min_rx 50 multiplier 3
 
router ospf 333
 router-id x.x.1.10
 ispf
 log-adjacency-changes
 timers throttle spf 100 500 5000
 timers throttle lsa all 100 500 5000
 timers lsa arrival 150
 timers pacing flood 15
 timers pacing retransmission 30
 redistribute bgp 65000 subnets
 passive-interface default
 no passive-interface GigabitEthernet1/1
 no passive-interface GigabitEthernet3/48
 network x.x.1.0 0.0.0.255 area 0
 network x.x.126.202 0.0.0.1 area 0
 network x.x.126.254 0.0.0.1 area 0
  bfd all-interfaces
 
router bgp 65000
 bgp router-id x.x.1.10
 no bgp default ipv4-unicast
 no bgp default route-target filter
 bgp log-neighbor-changes
 neighbor x.x.1.9 remote-as 65000
 neighbor x.x.1.9 update-source Loopback1
 neighbor x.x.1.50 remote-as 65000
 neighbor x.x.1.50 update-source Loopback1
 neighbor y.y.17.126 remote-as 64000
 neighbor y.y.17.126 ebgp-multihop 255
 neighbor y.y.17.126 update-source GigabitEthernet1/2
 neighbor y.y.17.126 fall-over bfd
 !
 address-family ipv4
  redistribute ospf 333
  neighbor x.x.1.9 activate
  neighbor x.x.1.9 send-community both
  neighbor x.x.1.9 send-label
  neighbor y.y.17.126 activate
  neighbor y.y.17.126 send-community both
  neighbor y.y.17.126 send-label
  no auto-summary
  no synchronization
 exit-address-family
 !
 address-family vpnv4
  neighbor x.x.1.9 activate
  neighbor x.x.1.9 send-community both
  neighbor x.x.1.50 activate
  neighbor x.x.1.50 send-community both
  neighbor x.x.1.50 route-reflector-client
  neighbor y.y.17.126 activate
  neighbor y.y.17.126 send-community both
  neighbor y.y.17.126 next-hop-unchanged
  bgp scan-time import 5
  bgp scan-time 5
 exit-address-family
 

 

Настройки RR и PE маршрутизаторов в Интернет-операторе Б производятся аналогично настройками Интернет-оператора А, за исключением настроек PE маршрутизаторов. В vrf`е необходимо добавить в импорт/экспорт rd обоих AS.

Level Up
Sponsors:

Контактная информация

Если у Вас есть какие-либо вопросы, Вы можете связаться с нами:

Отдел продаж: (с 10:00 до 18:00)

Icq: 155-10-6525

E-mail: sales@golas.ru